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1. General Information

This section of the documentation provides general information about the Financial Calculator computer program.

Financial Calculator is a computer program that allows you to create, edit, print and save financial reports.

Financial Calculator allows you to create financial reports that contain 32 compounding periods.

Financial Calculator allows you to create financial reports that contain up to 1024 financial transactions. 

Each Financial Calculator report contains 32 interest transactions. 

Loan transactions and payment transactions can be added to a compounding period by using the Add menu.

Each line of a Financial Calculator report is labeled with a unique identifier that indicates the period number, transaction number, and line number of the line.

At the end of each Financial Calculator report is a section that displays the balancing of transaction amounts.

Interest transaction amounts, loan transaction amounts and payment transaction amounts are grouped separately.

Each transaction amount is identified with a report line label.

A transaction amount total is displayed for each group.

A total transaction amount total is also displayed.

The section of the Financial Calculator report that displays the balancing of transaction amounts is designed to allow you to investigate the accuracy of the Financial Calculator report.

You can investigate the accuracy of the Financial Calculator report by comparing ending balance totals that have been derived in different but equivalent ways.

Financial Calculator allows you to exchange items of data with other Windows programs using standard copy and paste techniques.

Financial Calculator allows you to copy the entire Financial Calculator report to other Windows programs, such as Notepad, by using standard copy and paste techniques.

The Financial Calculator document can be saved as a comma delimited data file, which can be opened by other Windows programs such as Microsoft Excel, and Notepad.

The current version of Financial Calculator is designed to limit the value of the new rounding error per compounding period to less than += .00000000000000000001.

The current version of Financial Calculator is designed to limit the value of the total compounded rounding error per Financial Calculator document to less than +- .0000000001.

2. System Requirements

This section of the documentation provides information about the system requirements of the Financial Calculator program.

Financial Calculator is designed to run on a computer system, that provides the following requirements.

A Windows operating system is required. Financial Calculator is designed to run on a standard North American version of Windows that was manufactured this century. The documentation may differ slightly from the way Financial Calculator runs on your computer system, if your computer is equipped with an earlier version of Windows or a non-North-American version of Windows.

A keyboard is required. Financial Calculator is designed to use a standard North American keyboard. The documentation may differ slightly from the way Financial Calculator runs on your computer system, if your computer is equipped with a non-North-American keyboard.

A monitor is required.

An Internet connection is required to obtain a copy of the Financial Calculator program file from the Matthews Software Incorporated web site, www.matthewssoftware.ca .

A mouse device is required.

Access to a printer is required, to print the financial reports, you create.

Access to storage media is required to save the files you create.

3. How to start up the Financial Calculator program

This section of the documentation provides information about how to start up the Financial Calculator program.

You can start up the Financial Calculator program by following the steps described below.

First, display the Financial Calculator program file in Windows Explorer as illustrated below.
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You can select the Financial Calculator program file, FinancialCalculator.exe, by left clicking the program file with the mouse device, as shown below.

Then, press the Enter key, to start up the Financial Calculator program.
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The Financial Calculator User Agreement message box is displayed as illustrated below.

If you agree to the terms of the user agreement, left click the Yes button, with the mouse device.

If you do not agree to the terms of the user agreement, left click the No button with the mouse device.
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In the illustration below, the Yes button of the Financial Calculator User Agreement message box, has been left clicked with the mouse device.

The Financial Calculator program is now displayed, as shown below.
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4. How to maximize the Financial Calculator program window

This section of the documentation provides information about how to maximize the Financial Calculator program window.

You can display the full screen version of the Financial Calculator program window, by left clicking the Maximize button, with the mouse device.

The Maximize button is located in the upper right corner of the Financial Calculator program window as illustrated below.
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The full screen version of the Financial Calculator program is displayed below.
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5. How to set the Beginning Balance Sign parameter

This section of the documentation provides information about how to set the Beginning Balance Sign parameter.

To set the Beginning Balance parameter, first select the Beginning Balance Sign edit control, as shown below.
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You can select the Beginning Balance edit control by left clicking the edit control with the mouse device.
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When the Beginning Balance Sign edit control has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Beginning Balance Sign edit control, the current value of the Beginning Balance Sign parameter is displayed.

In the illustration above the value “+” is displayed.

You can edit the value displayed by the Beginning Balance Sign edit control by using the “+” keyboard key or the “-“ keyboard key.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Beginning Balance Sign edit control.

You can also use the standard copy and paste techniques to edit the value displayed by the Beginning Balance Sign edit control.

In the example below, the value displayed by the Beginning Balance Sign edit control has been set to  “-“.

The Transaction List has not yet been updated, as seen in the illustration below.
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Once you have set the value displayed by the Beginning Balance Sign edit control, you can update the Transaction List with the new data value, by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key.

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Beginning Balance Sign edit control was set to “-“ by pressing the “-“ key.

Then the Enter key was pressed to update the Transaction List with the new data value.
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As shown below, the new data value is now displayed by the Transaction List.
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6. How to set the Beginning Balance Whole Number parameter

This section of the documentation provides information about how to set the Beginning Balance Whole Number parameter.

To set the Beginning Balance Whole Number parameter, first select the Beginning Balance Whole Number edit control, as shown below.
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You can select the Beginning Balance Whole Number edit control by left clicking the edit control with the mouse device.
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When the Beginning Balance Whole Number edit control has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Beginning Balance Whole Number edit control, the current value of the Beginning Balance Whole Number parameter is displayed.

In the illustration above, the value “000000000000000000000” is displayed.

You can edit the value displayed by the Beginning Balance Whole Number edit control by using the “0” to “9” keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key, and the Left Arrow key to edit the value displayed by the Beginning Balance Whole Number edit control.

You can also use the standard copy and paste techniques to edit the value displayed by the Beginning Balance Whole Number edit control.

In the example below, the value displayed by the Beginning Balance Whole Number edit control has been set to “100”.

The Transaction List has not yet been updated, as seen in the illustration below.
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Once you have set the value displayed by the Beginning Balance Whole Number edit control, you can update the Transaction List with the new data value, by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key.

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Beginning Balance Whole Number edit control was set to “100” by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.
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As shown below, the new data value is now displayed by the Transaction List.
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7. How to set the Beginning Balance Decimal Number parameter

This section of the documentation provides information about how to set the Beginning Balance Decimal Number parameter.

To set the Beginning Balance Decimal Number parameter, first select the Beginning Balance Decimal Number edit control, as shown below.
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You can select the Beginning Balance Decimal Number edit control, by left clicking the edit control with the mouse device.
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When the Beginning Balance Decimal Number edit control has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Beginning Balance Decimal Number edit control, the current value of the Beginning Balance Decimal Number parameter is displayed.

In the illustration above, the value “00000000000000000000” is displayed.

You can edit the value displayed by the Beginning Balance Decimal Number edit control by using the “0” to “9” keyboard keys.

You can also use the Backspace key, the Delete key, 

The Right Arrow key, and the Left Arrow key to edit the value displayed by the Beginning Balance Decimal Number edit control.

You can also use the standard copy and paste techniques to edit the value displayed by the Beginning Balance Decimal Number edit control.

In the example below, the value displayed by the Beginning Balance Decimal Number edit control has been set to “99”.

The Transaction List has not been updated, as seen in the illustration below.
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Once you have set the value displayed by the Beginning Balance Decimal Number edit control, you can update the Transaction List with the new data value, by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key.

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Beginning Balance Decimal Number edit control was set to “99” by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.
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As shown below, the new data value is now displayed by the Transaction List.
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8. How to set the Interest Rate Per Period Decimal Number parameter

This section of the documentation provides information about how to set the Interest Rate Per Period Decimal Number parameter.

To set the Interest Rate Per Period Decimal Number parameter, first select the Interest Rate Per Period Decimal Number edit control, as shown below.
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You can select the Interest Rate Per Period Decimal Number edit control by left clicking the edit control with the mouse device.
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When the Interest Rate Per Period Decimal Number edit control has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Interest Rate Per Period Decimal Number edit control, the current value of the Interest Rate Per Period Decimal Number parameter is displayed.

In the illustration above, the value “00000000000000000000” is displayed.

You can edit the value displayed by the Interest Rate Per Period Decimal Number edit control by using the “0” to “9” keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Interest Rate Per Period Decimal Number edit control.

You can also use the standard copy and paste techniques to edit the value displayed by the Interest Rate Per Period Decimal Number edit control.

In the example below, the value displayed by the Interest Rate Per Period Decimal Number edit control has been set to “01”.

The Transaction List has not yet been updated, as seen in the illustration below.
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Once you have set the value displayed by the Interest Rate Per Period Decimal Number edit control, you can update the Transaction List with the new data value, by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key.

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Interest Rate Per Period Decimal Number edit control was set to “01” by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.
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As shown below, the new data value is now displayed by the Transaction List.
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9. How to set the Comment parameter of an interest transaction

This section of the documentation provides information about how to set the Comment parameter of an interest transaction.

To set the Comment parameter of an interest transaction, first select the Comment edit control of the interest transaction, as shown below.
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You can select the Comment edit control of an interest transaction by left clicking the edit control with the mouse device.
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When the Comment edit control of an interest transaction has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Comment edit control of an interest transaction, the current value of the Comment parameter of the transaction is displayed.

In the illustration above an empty string value “” is displayed.

You can edit the value displayed by the Comment edit control of an interest transaction, by using the alphabetic or numeric keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Comment edit control of an interest transaction.

You can also use the standard copy and paste techniques to edit the value displayed by the Comment edit control of an interest transaction.

In the example below, the value displayed by the Comment edit control of an interest transaction has been set to “January 1, 2012”.

Because the Enter key has not yet been pressed, the Transaction List has not yet been updated.
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Once you have set the value displayed by the Comment edit control of an interest transaction, you can update the Transaction List with the new data value, by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key.

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Comment edit control of an interest transaction was set to “January 1, 2012” by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.

As shown below, the new data value is displayed by the Transaction List.
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10. How to print the Transaction List report

This section of the documentation provides information about how to print the Transaction List report.

To print the Transaction List report, first left click the File menu with the mouse device.

From the drop down list that is displayed, select the Print... menu item as illustrated below.

You can select the Print... menu item by left clicking the Print... menu item with the mouse device.
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After selecting the Print... menu item from the File menu, the Print dialog box is displayed as illustrated below.

You can use the Print dialog box to specify the Printer you wish to use.

You can also use the Print dialog box to set the specifications of the Printer you have chosen.

The Transaction List report is designed to print on paper that is 8&1/2 inches wide and 11 inches long.

This is commonly referred to as Letter Size paper.
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To print the Transaction List report to the printer you have selected, left click the Print button displayed by the Print dialog box.

11. How to copy the Transaction List report to other Windows programs

This section of the documentation provides information about how to copy the Transaction List report to other Windows programs.

To copy the Transaction List report to other Windows programs, first left click the Edit menu with the mouse device.

From the drop down list that is displayed, select the Select All menu item as illustrated below.

You can select the Select All menu item by left clicking the Select All menu item with the mouse device.
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After selecting the Select All menu item from the Edit menu, the text to be copied to other Windows programs is highlighted as shown below.

[image: image80.png]Microsoft Excel - Book1

|®)Eile Edit View Insert Format Tools Data Window Help

-ls|x

DR SRy

$BBY[0 - (A® = AN WEH - D)

=

-0 - B ZU

B %%, %9

Ha3

ot u

A

B © D E

F G H

Open

advanced.

Find les that match these search creria

File pame:

Files of type:

] Text or property

End Now

[Mierasoft Excel s

=] Lest modied:

o time:

Newsearch

[0 file(s) found.

Sheet1 / Sheet2 / Sheet3





In the illustration below, the Select All menu item has been selected from the Edit menu.

To copy the selected text to other Windows programs, select the Edit menu from the menu bar and then left click the Copy menu item as shown below.

After selecting the Copy menu item from the Edit menu as described above, a copy of the Transaction List report is copied to the Windows Clipboard object.

The Transaction List report can now be pasted into other Windows programs.
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In the illustration below, the Notepad program window is displayed.

Notepad is a text editor program that is part of the Windows operating system.
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After copying the Transaction List report to the Windows Clipboard Object as described above, you can paste a copy of the Transaction List report into the Notepad text editor program by selecting the Paste menu item from the Edit menu.

First left click the Edit menu on the menu bar and then select the Paste menu item from the drop down list as illustrated below.

You can select the Paste menu item by left clicking the Paste menu item with the mouse device.
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In the illustration below, a copy of the Transaction List report has been pasted into the Notepad text editor program.

The ending section of the Transaction List report is displayed.

The ending section of the Transaction List report displays the balancing of transaction amounts.

The ending section of the Transaction List report allows you to investigate the accuracy of the Transaction List report, by comparing ending balance totals that have been derived in different but equivalent ways.

[image: image84.png]Financial Calculator
File Edit Add About

Beginning balanc

] [ ooooooacoooacoooacooo | . [ coooacoooacoooaconoa
Incerest rave per period:

B . [ soos0os0030030030980

o1-0001a | ]

01-00016  Period: 01

1 3% Floppy (]
Wy Fecent Dacumerts
Deskion
() My Docurents
Dadiams | 3 My Conpute
B Y5 Flogy (2]
< LacalDik )
2 DVD-RW Diive (€]
2
Dskr | (5 SuredDocments
(23 My Documents

&0 My Network Places

My Docurents

File pame: InerestRiateDemo_1%cal

MyNatwork  Flesof e [Fnancil CalcuatorFies(-ca)
Plces

T~ Open as read-only

02-0001k New balanc
02-00011 +  0000000DO0000D00O00000 . 00O000000000000000000

03-0001a
03-00016  Period: 03
03-0001c  Trapsaction: 0001





In the illustration below the scrollbar control has been used to display the top of the Transaction List report.
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The Transaction List report was pasted into the Notepad text editor program using standard copy and paste techniques, as described above.

[image: image88.png]B Untitled - Notepad
File

Save
Save As

Page Setup.
Print.

Exit





12. How to save the Financial Calculator data      as a Financial Calculator data file

This section of the documentation provides information about how to save the Financial Calculator data as a Financial Calculator data file.

To save the Financial Calculator data as a Financial Calculator data file, first left click the File menu with the mouse device.

From the drop down list that is displayed, select the Save. . . menu item as illustrated below.

You can select the Save. . .  menu item by left clicking the Save. . . menu item with the mouse device.
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After selecting the Save. . . menu item from the File menu, the Save As dialog box is displayed as shown below.
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You can use the Save As type, list box of the Save As dialog box to specify if you would like to save the Financial Calculator data as a Financial Calculator data file or as a Comma Delimited data file.

If you choose to save the Financial Calculator data as a Financial Calculator data file, you can edit the Financial Calculator data file with the Financial Calculator program.

If you choose to save the Financial Calculator data as a Comma Delimited data file, the Comma Delimited data file can be opened by other Windows programs such as Microsoft Excel and Microsoft Notepad.

In the illustration below, the user has chosen to save the Financial Calculator data as a Financial Calculator data file by selecting the first menu item, the “Financial Calculator Files (*.cal)”, menu item from the Save as type list box. 
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You can use the Save In list box of the Save As dialog box to choose the directory where you would like to save the Financial Calculator data file.

You can specify the directory where you would like to save the Financial Calculator data file by left clicking one of the directories displayed by the Save In list box.

In the illustration below, the user has selected the root of the A: drive as the directory where he would like to save the Financial Calculator data file. 
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You can use the File Name edit control of the Save As dialog box to set the Filename parameter of the Financial Calculator data file.

When the File Name edit control has keyboard focus, you can set the value of the Filename parameter by using the keyboard keys.

In the illustration below, the Filename parameter has been set to “InterestRateDemo_1%.cal”.
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After selecting the “Financial Calculator Files (*.cal)” menu item from the Save As Type list box, you can save the Financial Calculator data as a Financial Calculator data file.

After selecting a directory where you would like to save the Financial Calculator data file, and providing a filename for the data file, you can save the Financial Calculator data file by left clicking the Save button of the Save As dialog box with the mouse device.
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After you save the Financial Calculator data as a Financial Calculator data file, the filename that you have provided is displayed in the title bar of the Financial Calculator program window.

In the illustration below, the Financial Calculator data file has been saved to the root of the A: drive.

The user has provided the filename “InterestRateDemo_1%.cal”.

Note that the filename is now displayed in the title bar of the Financial Calculator program window.
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13.  How to save the Financial Calculator data as a Comma Delimited data file

This section of the documentation provides information about how to save the Financial Calculator data as a Comma Delimited data file.

To save the Financial Calculator data as a Comma Delimited data file, first left click the File menu with the mouse device.

From the drop down list that is displayed, select the Save . . . menu item as illustrated below.

You can select the Save . . . menu item by left clicking the Save . . . menu item with the mouse device.
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After selecting the Save . . . menu item from the File menu, the Save As dialog box is displayed as shown below.
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You can use the Save As Type list box of the Save As dialog box to specify if you would like to save the Financial Calculator data as a Financial Calculator data file or as a Comma Delimited data file.

If you choose to save the Financial Calculator data as a Financial Calculator data file, you can edit the Financial Calculator data file with the Financial Calculator program.

If you choose to save the Financial Calculator data as a Comma Delimited data file, the Financial Calculator data will be saved in a text file format that is recognized by other Windows programs such as Microsoft Excel.

In the illustration below, the user has chosen to save the Financial Calculator data as a Comma Delimited data file, by selecting the second menu item, the “Data Files (Comma Delimited) (*.txt)”, menu item from the Save As Type list box.
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You can use the Save In list box of the Save As dialog box to choose the directory where you would like to save the Comma Delimited data file.

You can specify the directory where you would like to save the Comma Delimited data file by left clicking one of the directories displayed by the Save In list box.

In the illustration below, the user has selected the root of the A: drive as the directory where would like to save the Comma Delimited data file.
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You can use the File Name edit control of the Save As dialog box to set the Filename parameter of the Comma Delimited data file.

When the File Name edit control has keyboard focus, you can set the value of the Filename parameter by using the keyboard keys.

In the illustration below the Filename parameter has been set to “InterestRateDemo_1%_ExportableVersion.txt”.


After selecting the “Data Files (Comma Delimited) (*.txt)”, menu item from the Save As Type list box, you can save the Financial Calculator data as a Comma Delimited data file.

After selecting the directory where you would like to save the Comma Delimited data file, and providing a filename for the data file, you can save the Comma Delimited data file by left clicking the Save button of the Save As dialog box with the mouse device.


If you save the Financial Calculator data as a Financial Calculator data file, the Financial Calculator data file can be opened by the Financial Calculator program and the filename that you provided is displayed in the title bar of the Financial Calculator program.

If you save the Financial Calculator data as a Comma Delimited data file, the Comma Delimited data file can by opened by other Windows programs such as Microsoft Excel and Microsoft Notepad, but the Comma Delimited data file can not be opened by the Financial Calculator program.

If you save the Financial Calculator data as a Comma Delimited data file, the filename the you have provided is not displayed in the title bar of the Financial Calculator program window.

In the illustration below, the Financial Calculator data has been saved to the root of the A: drive as a Comma Delimited data file.

The user has provided the filename “InterestRateDemo_1%_ExportableVersion.txt”.

Note that the filename of the Comma Delimited data file is not displayed in the title bar of the Financial Calculator program window.


14.  How to open a Financial Calculator data file, that has been saved to your computer system, using the Financial Calculator program.

This section of the documentation provides information about how to open a Financial Calculator data file, that has been saved to your computer system, using the Financial Calculator program.

To open a Financial Calculator data file that has been saved to your computer system, using the Financial Calculator program, first left click the File menu with the mouse device.

From the drop down list that is displayed, select the Open. . . menu item as illustrated below.

You can select the Open. . . menu item by left clicking the Open. . . menu item with the mouse device.


After selecting the Open... menu item from the File menu, the Open dialog box is displayed as shown below.

You can use the Open dialog box to select the Financial Calculator data file that you would like to open.


The Open dialog box displays the files that are available to your computer system.

You can use the Look in list box to navigate to the directory where the file, you wish to open, is located.

In the example below, the user has selected the root of the A: drive as the directory he wishes to display.

You can select a directory from the Look in list box by left clicking the directory with the mouse device.


Once you have selected a directory from the Look in list box, as described above, the files stored in that directory are displayed.

You can select a Financial Calculator data file from the Open dialog box by left clicking the file with the mouse device.

In the example below, the user has selected the Financial Calculator data file, “InterestRateDemo_1%.cal”.


After selecting the Financial Calculator data file that you would like to open from the Open dialog box, as described above, you can open the file by left clicking the Open button, of the Open dialog box, with the mouse device.

After you open the Financial Calculator data file, the data contained in the Financial Calculator data file is displayed in the Financial Calculator program window.

You can use the Financial Calculator program to create a new report based on the Financial Calculator data file that was opened.

In the illustration below, the Financial Calculator data file, “InterestRateDemo_1%.cal”, was opened as described above.

Note that the filename of the Financial Calculator data file is now displayed in the title bar of the Financial Calculator program window.


15. How to open a Comma Delimited data file,     that has been saved to your computer system,   using the Microsoft Notepad text editor      program

This section of the documentation provides information about how to open a Comma Delimited data file, that has been saved to your computer system, using the Microsoft Notepad text editor program.

In the illustration below, the Microsoft Notepad text editor program window is displayed.

Microsoft Notepad is a text editor program that is part of the Windows operating system.


After saving the Financial Calculator data as a Comma Delimited data file as described above, you can open the Comma Delimited data file using the Microsoft Notepad, text editor program.

First, left click the File menu and then select the Open . . . menu item from the drop down list as illustrated below.

You can select the Open ... menu item, by left clicking the Open ... menu item with the mouse device.


After selecting the Open . . . menu item from the File menu, the Open dialog box is displayed as shown below.

You can use the Open dialog box to select the Comma Delimited data file that you would like to open.


The Open dialog box displays the files that are available to your computer system.

You can use the Look In list box to navigate to the directory where the file you wish to open is located.

In the example below, the user has selected the root of the A: drive as the directory he wishes to display.

You can select a directory from the Look In list box by left clicking the directory with the mouse device.


Once you have selected a directory from the Look In list box, as described above, the files stored in that directory are displayed.

You can select a Comma Delimited data file from the Open dialog box, by left clicking the file with the mouse device.

In the illustration below, the user has selected the Comma Delimited data file, “InterestRateDemo_1%_ExportableVersion.txt”.


After selecting the Comma Delimited data file that you would like to open from the Open dialog box, as described above, you can open the file by left clicking the Open button of the Open dialog box, with the mouse device.

After you open the Comma Delimited data file, the Financial Calculator data, contained in the Comma Delimited data file is displayed in the Microsoft Notepad program window.

You can use the Microsoft Notepad, text editor program to inspect the Financial Calculator data and to generate financial reports.

In the illustration below, the Comma Delimited data file, “InterestRateDemo_1%_ExportableVersion.txt”, was opened by the Microsoft Notepad text editor program as described above.

The filename of the Comma Delimited data file is displayed in the title bar of the Microsoft Notepad program window.


In the illustration below, the Comma Delimited data file that was opened using the Microsoft Notepad program as described above is displayed in the Microsoft Notepad program window.

The Comma Delimited data file was created by an instance of the Financial Calculator program, which is displayed in the foreground. 


The Comma Delimited data file displays the Financial Calculator data in a Comma Delimited Text File format.

One data record is generated for each transaction in the Financial Calculator transaction list.

Each data record contains 11 data items, which describe the properties of that transaction.

Each data item is enclosed with quotation marks and the data items are separated with a comma.

Each data record is ended with a carriage return – line feed character combination so that each data record starts at the beginning of a new line.

The first data item of a record describes the Comment property of the transaction and contains the information displayed by Line a of the Financial Calculator transaction.

The second data item of a record describes the Period property of the transaction and contains the information displayed by Line b of the Financial Calculator transaction.

The third data item of a record describes the Transaction Number property of the transaction and contains the information displayed by Line c of the Financial Calculator transaction.

The fourth data item of a record describes the Transaction Type property of the transaction and contains the information displayed by Line d of the Financial Calculator transaction. If the transaction is an Interest Transaction, the fourth data item contains the value “0”. If the transaction is a Loan Transaction, the fourth data item contains the value “1”. If the transaction is a Payment Transaction, the fourth data item contains the value “2”.

The fifth data item of a record describes the Old Balance property of the transaction and contains the information displayed by Line f of the Financial Calculator transaction.

The sixth data item of a record contains a formula that describes how the value of the fifth data item was calculated.

The seventh data item of a record describes the Interest Rate Per Period property of the transaction and contains the information displayed by line h of the Financial Calculator transaction.

The eighth data item of a record describes the Amount property of the transaction and contains the information displayed by Line j of the Financial Calculator transaction.

The ninth data item of a record contains a formula that describes how the value of the eighth data item was calculated.

The tenth data item of a record describes the New Balance property of the transaction and contains the information displayed by Line l of the Financial Calculator transaction.

The eleventh data item of a record contains a formula that describes how the value of the tenth data item was calculated. 

16. How to open a Comma Delimited data file, that has been saved to your computer system, using the Microsoft Excel data spreadsheet program

This section of the documentation provides information about how to open a Comma Delimited data file, that has been saved to your computer system, using the Microsoft Excel data spreadsheet program.

In the illustration below, an instance of the Microsoft Excel 97 computer program is displayed.

Microsoft Excel 97 is a data spreadsheet program that is commonly used to make financial calculations and to generate financial reports.


After saving your Financial Calculator data as a Comma Delimited data file, as described above, you can open the Comma Delimited data file using the Microsoft Excel 97, data spreadsheet program.

First, left click the File menu and then select the Open . . . menu item from the drop down list as illustrated below.

You can select the Open . . . menu item, by left clicking the Open . . . menu item with the mouse device.




After selecting the Open . . . menu item from the File menu, the Open dialog box is displayed as shown below.

You can use the Open dialog box to select the Comma Delimited data file that you would like to open.




The Open dialog box displays the files that are available to your computer system.

You can use the Look In list box to navigate to the directory where the file you wish to open is located.

In the example below the user has selected the root of the A: drive as the directory he wishes to display.

You can select a directory from the Look In list box, by left clicking the directory with the mouse device.



You can use the Files of Type list box to specify what types of files you would like the Open dialog box to display.

In the illustration below, the user has chosen the All Files list item from the Files of Type list box in order to display the Comma Delimited data file that he wishes to open using Microsoft Excel. 



Once you have selected a directory from the Look In list box and have selected the All Files list item from the Files of Type list box as described above, the Comma Delimited data files stored in that directory are displayed.

You can select a Comma Delimited data file from the Open dialog box, by left clicking the file with the mouse device.

In the illustration below, the user has selected the Comma Delimited data file, “InterestRateDemo_1%_ExportableVersion.txt”.



After selecting the Comma Delimited data file that you would like to open from the Open dialog box as described above, you can open the file by left clicking the Open button of the Open dialog box with the mouse device.



After selecting the Open button of the Open dialog box as described above, the Text Import Wizard dialog box is displayed by the Microsoft Excel 97 data spreadsheet program.

You can follow the instructions displayed by the Text Import Wizard dialog box to open the Comma Delimited data file into a Microsoft Excel 97 worksheet. 



You can use the Text Import Wizard to open the Comma Delimited data file that contains your Financial Calculator data, into the Microsoft Excel 97 data spreadsheet program.

In the illustration below, the user has selected the Delimited option button, in the Step 1 of 3 dialog box of the Text Import Wizard.

You can continue to the next step by selecting the Next button.



In the illustration below, the user has selected the selected the Comma check box in the Step 2 of 3 dialog box.

After selecting the Comma check box as illustrated below, you can continue to the Step 3 of 3 dialog box by left clicking the Next button with the mouse device. 



In the illustration below, the Step 3 of 3 dialog box is displayed.

In the illustration below, the user has set the data format to Text for Column 1, Column 5, Column 7, Column 8, and Column 10.

The user has set the data format to General for all other columns.

After configuring the Text Import Wizard dialog box as described above, you can open the Comma Delimited data file using Microsoft Excel 97, by left clicking the Finish button.



In the illustration below, the user saved the Financial Calculator data as a Comma Delimited data file using the Financial Calculator program.

After saving the Financial Calculator data as a Comma Delimited data file, using the Financial Calculator program, the user opened the Comma Delimited data file using the Microsoft Excel 97 data spreadsheet program.

After configuring the Step 1 of 3 dialog box, the Step 2 of 3 dialog box and the Step 3 of 3 dialog box, as described above and left clicking the Finish button, the Comma Delimited data file was displayed in the program window of the Microsoft Excel 97 data spreadsheet program as shown below.


In the illustration below, the user has applied the AutoFit Column Width Selection to more clearly display the data contained by the Microsoft Excel 97 data spreadsheet program.

An instance of the Financial Calculator program that was used to generate the Comma Delimited data file, “InterestRateDemo_1%_ExportableVersion.txt”, is displayed in the foreground.


17. How to start a new Financial Calculator document

This section of the documentation provides information about how to start a new Financial Calculator document.

To start a new Financial Calculator document first left click the File menu with the mouse device.

From the drop down list that is displayed, select the New menu item as illustrated below.

You can select the New menu item by left clicking the New menu item with the mouse device.


After selecting the New menu item from the File menu a new Financial Calculator document is displayed in the Financial Calculator program window.

In the illustration below, the New menu item, of the File menu, has been selected and a new Financial Calculator document is displayed in the program window.


A new Financial Calculator document displays the properties described below.

The title bar of a new Financial Calculator document displays the title “Financial Calculator”.

The Beginning Balance Sign parameter of a new Financial Calculator document is initialized to “+”.

The Beginning Balance Whole Number parameter of a new Financial Calculator document is initialized to “000000000000000000000”.

The Beginning Balance Decimal Number parameter of a new Financial Calculator document is initialized to “00000000000000000000”.

The Interest Rate Per Period Decimal Number parameter of a new Financial Calculator document is initialized to “00000000000000000000”.

A new Financial Calculator document contains 32 Interest transactions.

The Comment parameter, of each Interest Transaction in a new Financial Calculator document, is initialized to the empty string value, “”.

A new Financial Calculator document contains 0 Loan Transactions.

A new Financial Calculator document contains 0 Payment Transactions.

The Beginning Balance Sign edit control is the selected control of a new Financial Calculator document and displays a double thickness selection rectangle as illustrated above.

A new Financial Calculator document is also displayed when the Financial Calculator program first starts up.

In the illustration below, the Financial Calculator program has just started up, and a new Financial Calculator document is displayed in the program window.


18.  How to add a loan transaction to a Financial Calculator document

This section of the documentation provides information about how to add a loan transaction to a Financial Calculator document.

To add a loan transaction to a Financial Calculator document, first left click the Add menu with the mouse device.

From the drop down list that is displayed select the Add Loan Transaction to Period: menu item as illustrated below.


To add a loan transaction to a Financial Calculator document, you must select the number of the period where you wish to add the loan transaction.

You can select the number of the period where you wish to add a loan transaction by left clicking the menu item that displays the appropriate period number.

In the illustration below, the user has chosen to add a loan transaction to Period 01 of the Financial Calculator document.


In the illustration below, a loan transaction has been added to Period 01 of the current Financial Calculator document as described above.

The Period number of the new loan transaction, Period: 01, is displayed on Line 01-0002b of the Financial Calculator document, as shown above.

The Transaction number of the new loan transaction, Transaction: 0002, is displayed on Line 01-0002c of the Financial Calculator document, as shown above.

The Transaction type of the new loan transaction, Type: Loan transaction, is displayed on Line 01-0002d of the Financial Calculator document, as shown above.

19. How to set the Comment parameter of a loan transaction

This section of the documentation provides information about how to set the Comment parameter of a loan transaction.

To set the Comment parameter of a loan transaction, first select the Comment edit control of the loan transaction, as shown below.

You can select the Comment edit control of a loan transaction by left clicking the edit control with the mouse device.


When the Comment edit control of a loan transaction has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Comment edit control of a loan transaction, the current value of the Comment parameter of the transaction is displayed.

In the illustration above an empty string value, “”, is displayed.

You can edit the value displayed by the Comment edit control of a loan transaction, by using the alphabetic and the numeric keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Comment edit control of a loan transaction.

You can also use the standard copy and paste techniques to edit the value displayed by the Comment edit control of a loan transaction.

In the example below, the value displayed by the Comment edit control of a loan transaction has been set to “January 1, 2012”.

Because the Enter key has not yet been pressed, the Transaction List has not yet been updated.


Once you have set the value displayed by the Comment edit control of a loan transaction, you can update the Transaction List with the new data value, by pressing the Enter key.

You can also update the Transaction List with the new data value, by pressing the Tab key.

You can also update the Transaction List with the new data value, by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Comment edit control of a loan transaction was set to “January 1, 2012”, by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.

As shown below, the new data value is displayed by the Transaction List.


20.  How to set the Amount Whole Number parameter of a loan transaction

This section of the documentation provides information about how to set the Amount Whole Number parameter of a loan transaction.

To set the Amount Whole Number parameter of a loan transaction, first select the Amount Whole Number edit control of the loan transaction, as shown below.

You can select the Amount Whole Number edit control of a loan transaction by left clicking the edit control with the mouse device.


When the Amount Whole Number edit control of a loan transaction has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Amount Whole Number edit control of a loan transaction, the current value of the Amount Whole Number parameter is displayed.

In the illustration above, the value “000000000000000000000” is displayed.

You can edit the value displayed by the Amount Whole Number edit control by using the “0” to “9” keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Amount Whole Number edit control.

You can also use the standard copy and paste techniques to edit the value displayed by the Amount Whole Number edit control.

In the example below, the value displayed by the Amount Whole Number edit control, of a loan transaction, has been set to “100”.

The Transaction list has not yet been updated, as seen in the illustration below.


Once you have set the value displayed by the Amount Whole Number edit control, you can update the Transaction List with the new data value by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key. 

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Amount Whole Number edit control, of a loan transaction, was set to “100” by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.

As shown below, the new data value has been incorporated into the calculated values displayed by the Transaction List.



21.  How to set the Amount Decimal Number parameter of a loan transaction

This section of the documentation provides information about how to set the Amount Decimal Number parameter of a loan transaction.

To set the Amount Decimal Number parameter of a loan transaction, first select the Amount Decimal Number edit control of the loan transaction, as shown below.

You can select the Amount Decimal Number edit control of a loan transaction by left clicking the edit control with the mouse device.


When the Amount Decimal Number edit control of a loan transaction has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Amount Decimal Number edit control of a loan transaction, the current value of the Amount Decimal Number parameter is displayed.

In the illustration above, the value “00000000000000000000” is displayed.

You can edit the value displayed by the Amount Decimal Number edit control by using the “0” to “9” keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Amount Decimal Number edit control.

You can also use the standard copy and paste techniques to edit the value displayed by the Amount Decimal Number edit control.

In the example below, the value displayed by the Amount Decimal Number edit control, of a loan transaction is “25”.

The Transaction list has not yet been updated, as seen in the illustration below.


Once you have set the value displayed by the Amount Decimal Number edit control, you can update the Transaction List with the new data value by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key.

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Amount Decimal Number edit control, of a loan transaction, was set to “25” by using the keyboard keys.

Then the Enter key was pressed to update the Transaction list with the new data value.

As shown below, the new data value has been incorporated into the calculated values displayed by the Transaction List.



22.  How to add a payment transaction to a Financial Calculator document

This section of the documentation provides information about how to add a payment transaction to a Financial Calculator document.

To add a payment transaction to a Financial Calculator document, first left click the Add menu with the mouse device.

From the drop down list that is displayed select the Add Payment Transaction to Period: menu item as illustrated below.


To add a payment transaction to a Financial Calculator document, you must select the number of the period where you wish to add the payment transaction.

You can select the number of the period where you wish to add a payment transaction by left clicking the menu item that displays the appropriate period number.

In the illustration below, the user has chosen to add a payment transaction to Period 01 of the Financial Calculator document.


In the illustration below, a payment transaction has been added to Period 01 of the current Financial Calculator document as described above.

The Period number of the new payment transaction, Period: 01, is displayed on line 01-0002b of the Financial Calculator document, as shown above.

The Transaction number of the new payment transaction, Transaction: 0002, is displayed on Line 01-0002c of the Financial Calculator document as shown above.

The Transaction type of the new payment transaction, Type: Payment transaction, is displayed on Line 01-0002d of the Financial Calculator document, as shown above.

23.  How to set the Comment parameter of a payment transaction

This section of the documentation provides information about how to set the Comment parameter of a payment transaction.

To set the Comment parameter of a payment transaction, first select the Comment edit control of the payment transaction as shown below.

You can select the Comment edit control of a payment transaction by left clicking the edit control with the mouse device.


When the Comment edit control of a payment transaction has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Comment edit control of a payment transaction, the current value of the Comment parameter of the transaction is displayed.

In the illustration above an empty string value, “”, is displayed.

You can edit the value displayed by the Comment edit control of a payment transaction by using the alphabetic and the numeric keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Comment edit control of a payment transaction.

You can also use the standard copy and paste techniques to edit the value displayed by the Comment edit control of a payment transaction.

In the example below, the value displayed by the Comment edit control of a payment transaction has been set to “January 1, 2012”.

Because the Enter key has not yet been pressed, the Transaction List has not yet been updated.


Once you have set the value displayed by the Comment edit control of a payment transaction, you can update the Transaction List with the new data value, by pressing the Enter key.

You can also update the Transaction List with the new data value, by pressing the Tab key.

You can also update the Transaction List with the new data value, by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Comment edit control of a payment transaction was set to “January 1, 2012”, by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.

As shown below, the new data value is displayed by the Transaction List.


24.  How to set the Amount Whole Number parameter of a payment transaction

This section of the documentation provides information about how to set the Amount Whole Number parameter of a payment transaction.

To set the Amount Whole Number parameter of a payment transaction, first select the Amount Whole Number edit control of the payment transaction, as shown below.

You can select the Amount Whole Number edit control of a payment transaction by left clicking the edit control with the mouse device.


When the Amount Whole Number edit control of a payment transaction has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Amount Whole Number edit control of a payment transaction, the current value of the Amount Whole Number parameter is displayed.

In the illustration above, the value “000000000000000000000” is displayed.

You can edit the value displayed by the Amount Whole Number edit control by using the “0” to “9” keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Amount Whole Number edit control.

You can also use the standard copy and paste techniques to edit the value displayed by the Amount Whole Number edit control.

In the example below, the value displayed by the Amount Whole Number edit control, of a payment transaction, has been set to “100”.

The Transaction List has not yet been updated, as seen in the illustration below.


Once you have set the value displayed by the Amount Whole Number edit control, you can update the Transaction List with the new data value by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key.

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Amount Whole Number edit control, of a payment transaction, was set to “100” by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.

As shown below, the new data value has been incorporated into the calculated values displayed by the Transaction List.


25.  How to set the Amount Decimal Number parameter of a payment transaction

This section of the documentation provides information about how to set the Amount Decimal Number parameter of a payment transaction.

To set the Amount Decimal Number parameter of a payment transaction, first select the Amount Decimal Number edit control of the payment transaction, as shown below.

You can select the Amount Decimal Number edit control, of a payment transaction by left clicking the edit control with the mouse device.


When the Amount Decimal Number edit control of a payment transaction has focus, it displays a double thickness selection rectangle as illustrated above.

When you first select the Amount Decimal Number edit control of a payment transaction, the current value of the Amount Decimal Number parameter is displayed.

In the illustration above, the value “00000000000000000000” is displayed.

You can edit the value displayed by the Amount Decimal Number edit control by using the “0” to “9” keyboard keys.

You can also use the Backspace key, the Delete key, the Right Arrow key and the Left Arrow key to edit the value displayed by the Amount Decimal Number edit control.

You can also use the standard copy and paste techniques to edit the value displayed by the Amount Decimal Number edit control.

In the example below, the value displayed by the Amount Decimal Number edit control, of a payment transaction is “25”.

The Transaction List has not yet been updated, as seen in the illustration below.


Once you have set the value displayed by the Amount Decimal Number edit control, you can update the Transaction List with the new data value by pressing the Enter key.

You can also update the Transaction List with the new data value by pressing the Tab key.

You can also update the Transaction List with the new data value by left clicking an edit control with the mouse device.

In the illustration below, the value displayed by the Amount Decimal Number edit control, of a payment transaction, was set to “25” by using the keyboard keys.

Then the Enter key was pressed to update the Transaction List with the new data value.

As shown below, the new data value has been incorporated into the calculated values displayed by the Transaction List.


26.  How to display copyright information about the Financial Calculator computer program

This section of the documentation provides information about how to display copyright information about the Financial Calculator computer program.

To display copyright information about the Financial Calculator computer program, first left click the About menu item with the mouse device.

From the drop down list that is displayed, select the About Financial Calculator. . . menu item, as illustrated below.


In the illustration below, the About Financial Calculator. . . menu item has been selected from the About menu.

The Financial Calculator message box is displayed as illustrated below.

The Financial Calculator message box provides copyright information about the Financial Calculator computer program.


27.  How to exit from the Financial Calculator computer program

This section of the documentation provides information about how to exit from the Financial Calculator computer program.

To exit from the Financial Calculator computer program, first left click the File menu with the mouse device.

From the drop down list that is displayed, select the Exit menu item as illustrated below.


28.  How to scroll a Financial Calculator document by using the Down Arrow key.

This section of the documentation provides information about how to scroll a Financial Calculator document by using the Down Arrow key.

In the illustration below, a Financial Calculator document is displayed.

The line label of the line displayed at the top of the Transaction List is “02-0001a”.


In the illustration below, the Down Arrow key was pressed to scroll the Financial Calculator document downward by one line.

The line label of the line which is now displayed at the top of the Transaction List is “02-0001b”.


29.  How to scroll a Financial Calculator document by using the Up Arrow key

This section of the documentation provides information about how to scroll a Financial Calculator document by using the Up Arrow key.

In the illustration below, a Financial Calculator document is displayed.

The line label of the line displayed at the top of the Transaction List is “02-0001a”.


In the illustration below, the Up Arrow key was pressed to scroll the Financial Calculator document upward by one line.

The line label of the line which is now displayed at the top of the Transaction List is “01-0001l”.


30.  How to scroll a Financial Calculator document by using the Page Down key

This section of the documentation provides information about how to scroll a Financial Calculator document by using the Page Down key.

In the illustration below, a Financial Calculator document is displayed.

The line label of the line displayed at the bottom of the program window is “03-0001g”.


In the illustration below, the Page Down key was pressed to scroll the Financial Calculator document downward by the number of lines displayed at one time in the program window. 

The line with line label “03-0001g” was displayed at the bottom of the Financial Calculator program window.

After pressing the Page Down key, the line with line label “03-0001g” is now displayed at the top of the Financial Calculator program window, as illustrated below.


31.  How to scroll a Financial Calculator document by using the Page Up key

This section of the documentation provides information about how to scroll a Financial Calculator document by using the Page Up key.

In the illustration below, a Financial Calculator document is displayed.

The line label of the line displayed at the top of the Transaction List is “08-0001a”.


In the illustration below, the Page Up key was pressed to scroll the Financial Calculator document upward by the number of lines displayed at one time in the program window.

The line with line label “08-0001a” was displayed at the top of the Transaction List.

After pressing the Page Up key, the line with line label “08-0001a” is now displayed at the bottom of the Financial Calculator program window, as illustrated below.


32.  How to scroll a Financial Calculator document by using the End key

This section of the documentation provides information about how to scroll a Financial Calculator document by using the End key.

In the illustration below, a Financial Calculator document is displayed.

The line label of the line displayed at the top of the Transaction List is “18-0001a”.

The scroll box is positioned at the middle of the vertical scrollbar control, which indicates that the middle of the Financial Calculator document is currently displayed in the program window.


In the illustration below, the End key was pressed to scroll the Financial Calculator document downward to the last line of the document.

The line with line label “18-0001a” was displayed at the top of the top of the Transaction List.

After pressing the End key, the last line of the Financial Calculator document is displayed at the bottom of the program window.

The scroll box is now positioned at the very bottom of the vertical scrollbar control.




33.  How to scroll a Financial Calculator document by using the Home key

This section of the documentation provides information about how to scroll a Financial Calculator document by using the Home key.

In the illustration below a Financial Calculator document is displayed.

The line label of the line displayed at the top of the Transaction List is “18-0001a”.

The scroll box is positioned at the middle of the vertical scrollbar control, which indicates that the middle of the Financial Calculator document is currently displayed in the program window.


In the illustration below, the Home key was pressed to scroll the Financial Calculator document to the first line of the document.

The line with label “18-0001a” was displayed at the top of the Transaction List.

After pressing the Home key, the first line of the Financial Calculator document is displayed at the top of the Transaction List.

The scroll box is now positioned at the very top of the vertical scrollbar control.
























































































































































































































































































































































The Next button





The Next button





The Text Import Wizard – Step 1 of 3 dialog box is displayed.





The Comma Delimited data file, “InterestRateDemo_1%_ExportableVersion.txt”, has been selected.





The user has selected the All Files list item of the Files Of Type list box.





The Look In list box displays the file directories that your computer system can access.





The Open dialog box is displayed.





The File menu





The Finish button





The Data Format property of Column 2, Column 3, Column 4, Column 6, Column 9 and Column 11 has been set to General.





The Data Format property of Column 1, Column 5, Column 7, Column 8, and Column 10 has been set to Text.





The Comma check box has been selected.





The Delimited option button has been selected.





The Open button





The scroll box





The scroll box





The scroll box





The scroll box





The new data value has been incorporated into the Transaction List calculations.





The Transaction List has not yet been updated.





The Amount Decimal Number edit control of a Payment transaction





The Amount Decimal Number edit control of a Payment transaction





The new data value has been incorporated into the Transaction List calculations.





The Transaction List has not yet been updated.





The Amount Whole Number edit control of a Payment transaction





The Amount Whole Number edit control of a Payment transaction





The new data value is displayed by the Transaction List.





The new data value has been incorporated into the Transaction List calculations.





The Transaction List has not yet been updated.





The Amount Decimal Number edit control of a Loan transaction





The Amount Decimal Number edit control of a Loan transaction





The new data value has now been incorporated into the Transaction List calculations





The Transaction list has not yet been updated.





The Amount Whole Number edit control of a Loan transaction





The Amount Whole Number edit control of a Loan transaction





The new data value is displayed by the Transaction List.





The Comment edit control of a Loan transaction





Scrollbar control





The new data value is displayed by the Transaction List.





The Comment edit control of an Interest transaction 





The new data value is now displayed by the Transaction List.





The Transaction List has not yet been updated





The Interest Rate Per Period Decimal Number edit control





The Interest Rate Per Period Decimal Number edit control





The new data value is now displayed by the Transaction List





The Transaction List has not yet been updated.





The Beginning Balance Decimal Number edit control





The Beginning Balance Decimal Number edit control





The new data value is now displayed by the Transaction List.





The Transaction List has not yet been updated.





The new data value is now displayed by the Transaction List.





The Transaction List has not yet been updated





The Beginning Balance Sign edit control





The Beginning Balance Whole Number edit control





The Beginning Balance Whole Number edit control





The Beginning Balance Sign edit control





Maximize button
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